*** Fixed. BUG version 3.5.0 *** Template editing problems | Bug Reports | Forum

Please consider registering
Guest

Search

— Forum Scope —






— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
*** Fixed. BUG version 3.5.0 *** Template editing problems
Profile photo of qwert
qwert
Member
Members
Forum Posts: 5
Member Since:
December 10, 2016
sp_UserOfflineSmall Offline
1
December 18, 2016 - 8:59 am
sp_Permalink sp_Print

Hello,

I cannot edit template (open *.tpl files in editor at admin-panel):

"ERROR!
Konnte nicht geoffnet werden Verzeichnis!
Uberprufen Sie Ihre CHMOD Einstellungen. Die Vorlagen-Verzeichnis und Dateien sollten auf CHMOD 0777 gesetzt werden."

"ERROR!
Could not open directory!
Check your CHMOD settings. The templates directory and files should be set to CHMOD 0777."

Please note, that I followed all instructions from file readme.html. And additionally, I have set 777 on all files in the directory "templates" (in accordance with the above mentioned error). And still this error.

In this regard, please specify what files else I have CHMOD777?

Thanks.

Profile photo of RedWine
RedWine
Member
Forum Posts: 549
Member Since:
January 6, 2016
sp_UserOfflineSmall Offline
2
December 18, 2016 - 9:44 am
sp_Permalink sp_Print

Thanks for catching this bug. Sanitizing the $_post value was sanitizing the path instead of just the file name and ended up removing the '..' from the relative path.

To fix this bug, do the following:

1- Open /admin/admin_editor.php
2- On LINE 66, replace this code:

$_POST["the_file"] = str_replace('..', '', $_POST["the_file"]);

with this:

$dir_name = dirname($_POST["the_file"]);
$base_name = basename($_POST["the_file"]);
$base_name = str_replace('..', '', $base_name);
$_POST["the_file"] = $dir_name . "/" . $base_name;

3- save the file and try it.

Profile photo of qwert
qwert
Member
Members
Forum Posts: 5
Member Since:
December 10, 2016
sp_UserOfflineSmall Offline
3
December 18, 2016 - 11:00 am
sp_Permalink sp_Print

1. Thanks. It works now.

2. Could I keep CHMOD 777 on *.tpl files in the directory "templates"?

P.S. In file readme.html in line:

"Make sure there are no error messages! If you see an error message, or if installation fails, report it here." - a broken link (404).

Profile photo of RedWine
RedWine
Member
Forum Posts: 549
Member Since:
January 6, 2016
sp_UserOfflineSmall Offline
4
December 18, 2016 - 11:26 am
sp_Permalink sp_Print

"2. Could I keep CHMOD 777 on *.tpl files in the directory "templates"?"

I am not sure why it says 777 in the error message!!! I will fix the message for the later version, because it is not really important for now, as long as the feature is working.

All the templates folders and files must be, by default:

/templates 755
/templates/ALL-THE FOLDERS-INSIDE IT 755
/temolates/ALL-THE FOLDERS-INSIDE IT/ALL-THE FILES-INSIDE 644

As for the broken link in the /readme.html

Open it in any editor you use and change the URL

from http://kliqqi.com/support/submit/

TO:

http://www.kliqqi.com/forum/

Thanks!

Profile photo of ABDUL AL MAMUN
ABDUL AL MAMUN
New Member
Members
Forum Posts: 2
Member Since:
December 10, 2016
sp_UserOfflineSmall Offline
5
December 18, 2016 - 1:26 pm
sp_Permalink sp_Print

thanks you very much
Our Website :http://migghub.com/

Profile photo of RedWine
RedWine
Member
Forum Posts: 549
Member Since:
January 6, 2016
sp_UserOfflineSmall Offline
6
December 18, 2016 - 1:30 pm
sp_Permalink sp_Print

ABDUL AL MAMUN said
thanks you very much
Our Website :http://migghub.com/  

We are glad you installed it. Start working on it and shuld you need any assistance, post a question here in the appropriate forum. All the best! 🙂

Profile photo of qwert
qwert
Member
Members
Forum Posts: 5
Member Since:
December 10, 2016
sp_UserOfflineSmall Offline
7
December 20, 2016 - 3:49 am
sp_Permalink sp_Print

Do You add all the fixed files (from topic "Bug Reports") in a distribution-pack for download, or not?

Profile photo of RedWine
RedWine
Member
Forum Posts: 549
Member Since:
January 6, 2016
sp_UserOfflineSmall Offline
8
December 20, 2016 - 6:59 am
sp_Permalink sp_Print

No, not yet. For now we post the fixes in the bug reports topic itself for users to grab it and make the modifications accordingly!

Forum Timezone: America/New_York

Most Users Ever Online: 27

Currently Online:
8 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Adam Burton: 103

DrCrash: 74

cyrus: 56

lipsmega: 45

Steven: 36

Newest Members:

LordWard

Demian

Jeff

jkctechnosoft Pvt Ltd

Marjun Guindulman

tonyzhang

Ali Raza Janjua

Rajat Jangra

aldimut

Rakshith

Forum Stats:

Groups: 1

Forums: 8

Topics: 290

Posts: 1592

 

Member Stats:

Guest Posters: 2

Members: 1061

Moderators: 2

Admins: 1

Administrators: ChuckRoast

Moderators: Kshitij Kumar, Mthobisi